1. Having troubles with activation email? Contact us at: Contact@FaceRig.us
    Dismiss Notice
  2. Hey Guest! We are giving away a FREE copy of FaceRig to one lucky member of FaceRig.US!!! Check out how you can get it by clicking here: http://facerig.us/index.php?threads/win-facerig-free.271
    Dismiss Notice
  3. It costs money to keep the site afloat. Guest, if you'd like to help us out and donate even $1 it will go a long way! Donate here:
    Dismiss Notice
  4. This is the fan-made / managed forum, for sharing community made content (avatars / props) The site owned / managed by the creators is https://facerig.com (currently down, we are working on it) The Steam forums are on http://steamcommunity.com/app/274920/discussions/
    Dismiss Notice

Strong Bad Custom Avatar Need Help Please!

Discussion in 'Questions & Queries' started by shock44, Jan 5, 2015.

  1. shock44
    Offline

    shock44 New Minion

    Messages:
    4
    Ratings:
    +0 / 0 / -0
    FR$:
    $0
    Hi, I've spent some time trying to get this model of Strong Bad working as a Custom Avatar in FaceRig. I got it to export okay, but when I load it up in FaceRig it just gives me a gray background. If I zoom out a bit I can see is gloves and nothing else. (Fluffo's apartment seems to display fine with the model though)

    [​IMG]

    Here is how the model should look and how I have it set up in Maya:

    [​IMG]

    I looked at how it re-did the TGA texture files and only the glove texture seems to have transferred well. The other textures are gray and I made sure I named them right as well as naming the materials right. The compiler made shd files for all the different materials I had. I tried applying the glove texture to Strong Bad's body to see if that would make it appear. However, that didn't help either so I am not sure what I am doing wrong here. Is there still not a step-by-step tutorial on how to make a custom avatar for FaceRig? Figuring this out on my own with just the documentation and avatar example is kind of hard. I'm glad I've come this far on my own. If someone here has an idea as to where I went wrong in my process let me know. If you need to know what certain things are named and how I have the model and textures set up I can tell you that. Thank you for your help.
     
  2. Navihawk
    Boxed In
    Offline

    Navihawk Ardalys' Rider

    Messages:
    173
    Ratings:
    +35 / 0 / -0
    FR$:
    $58
    Hm, could be issues with your shader assignments; also maybe a problem with the origin point of the model.
     
  3. shock44
    Offline

    shock44 New Minion

    Messages:
    4
    Ratings:
    +0 / 0 / -0
    FR$:
    $0
    Thank you for replying. Okay so I tried a different rip of the model that I had and now all but one texture shows up correctly. Also, the camera is still messed up to where I have to zoom out and it starts out inside his body.

    I decided to make a YouTube video to see if I can't get more help or help people understand my problem better. I'm sure if you watch the video you'll be able to tell me how to fix the one texture and the camera.



    Here is a link to my source files for the character as well: http://www.mediafire.com/download/n7dhr8tpx8ts5ad/StrongBad_FaceRig.zip
     
  4. Navihawk
    Boxed In
    Offline

    Navihawk Ardalys' Rider

    Messages:
    173
    Ratings:
    +35 / 0 / -0
    FR$:
    $58
    Ok, according to that video, the model needs to be rotated 180ยบ in your modeling software; that'll show the front of him at least. as for starting inside the model, try scaling him down in your modeling tools as well.
     
  5. shock44
    Offline

    shock44 New Minion

    Messages:
    4
    Ratings:
    +0 / 0 / -0
    FR$:
    $0
    Okay thanks. I'll give that a try. What about getting the alpha texture working?
     
  6. shock44
    Offline

    shock44 New Minion

    Messages:
    4
    Ratings:
    +0 / 0 / -0
    FR$:
    $0
    Is this not working well because I'm using Maya? Should I be using 3ds max or Blender or something else?
     

Share This Page